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Kstat is a set of macros added to Excel and it will enable you to do the statistics required for this 

course very easily.  To start Kstat, you need to open the Excel worksheet called Kstat.xls, as you 

would open any other worksheet.  The menu bar is the line near the top displaying the 

commands File, Edit, View, etc… After opening the file, note that in the menu bar there is an 

additional menu item called Statistics, which is not ordinarily there when you start Excel.  This 

item is added to the menu bar by Kstat.  Throughout this manual, commands on the main menu 

and sub-menus will be separated by the > sign.  For example, clicking Statistics > Charts > 

Residual Plots means doing this:  

 

 



You can either click on Statistics, then Charts, then Residual Plots (once each), or click on 

Statistics, hold the mouse button down as the sub-menus pop up, and release the button when 

you’ve gotten to Residual Plots.   

 

Getting Started 

 

First thing you should do is to click Statistics>Options and to check both options in the Global 

Options dialog box that appears. 

 

 

By checking the first box you will tell Excel not to overwrite the results of one regression when 

you run another during your Kstat session.  Checking the second box will allow Kstat to use the 

notation that we will be using throughout this course.  After you have checked both boxes click 

Done.  Now, you can click File>Save, and Kstat will save these options, so that you don’t have to 

do this every time you start Kstat.   

 

Worksheets are for listing and analyzing data and displaying the results of your analysis.  The 

names of the sheets appear on tabs at the bottom of the workbook window.  To move from sheet 

to sheet, you click the sheet tabs.  The name of the active sheet is always bold.  You can rename 

the sheets, add and delete sheets, and move or copy sheets within a workbook or to another 

workbook. 

 

Opening/Starting a Worksheet 

 

When Kstat starts, it will open a new workbook with only one worksheet, which is an empty 

worksheet called Data.  This is where all data you wish to analyze must be entered.  Usually you 

will want to load a data file (which you have previously downloaded) into Kstat To do this click 

Statistics>Import data>File…  You will see a window like the one below.  Choose the folder 
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that your data file is in, choose the data file and click Open.  For example, in the following 

window, by clicking Open, you can import the Capm.xls data set into Kstat.   

 

Once your data is in place the Data worksheet should look like this:  
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There are other ways to input data into Kstat.  If you have data in another Excel workbook, you 

can open that workbook in addition to Kstat, and then you can copy and paste the data to the Data 

worksheet of Kstat.  Occasionally, you may want to type in data manually.  To do this, begin 

entering the data starting from the cell A1.  Note that you must make sure that variable names are 

in row 1, that each column is one variable, and that the data is in consecutive columns.   

 

Basic Statistics and Critical Values 

 

With Kstat and Excel you can do some of the things you learned in DECS 433.  Import the data 

file adsales.xls, available at the course web-site.  Statistics > Univariate statistics will generate 

a number of useful summary statistics for each variable on the Data sheet.  The output looks like: 

 
Univariate statistics 

 exp sales 
mean 2.2900874 16.8873778

standard deviation 0.77765926 0.86660475

standard error of the mean 0.05929596 0.06607799

 
minimum 0.35679829 13.6289663

median 2.30022073 16.9419794

maximum 4.84897232 19.0247002

range 4.49217403 5.39573383

 
skewness 0.314 -0.826

kurtosis 0.568 1.996

 
number of observations 172

 

t-statistic for computing 
95%-confidence intervals 1.9739
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Statistics > Correlations finds the correlation coefficients between all possible pairs of variables 

in your data set.  Again using the adsales.xls data, we produce the following output: 
 

 

Correlations  

   

 exp Sales 
exp 1.00000 0.95549 

sales 0.95549 1.00000 

 

 

Here, 0.95549 is the correlation between exp and sales.  You can use the information provided in 

the univariate statistics output together with Excel’s TDIST function to perform a 1-Sample t-

test (which was covered in DECS-433).  To compare the means of two populations using a 

2-Sample t-test first click on an empty cell.  When you are done, Excel will put the result of the 

t-test in this cell.  We will use the Excel function called TTEST that returns the p-value 

associated with a Student's t-Test.  The syntax for this function is: 

TTEST(array1,array2,tails,type).  Here Array1 is the first variable, Array2 is the second 

variable, Tails specifies the number of tails to use for the test (If tails = 1, TTEST uses the one-

tailed distribution, if tails = 2, TTEST uses the two-tailed distribution), Type is the kind of t-Test 

to perform.  We will usually assume that the variances of the variables in a 2-sample t-test are 

different so you will choose 3 as the type of your test.   

 

There are two ways to use this function in Excel.  One way is clicking Insert>Function….  In 

the dialog box that appears choose Statistical as your function category and choose TTEST as 

your function name.  The dialog box should look like this:  
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When you click OK, you will obtain another dialog box.  In the Array 1 row enter the range of 

the first sample, in Array 2 row enter the range of the second sample, in the Tails row enter 1 if 

you want a one tail test and enter 2 if you want a two tail test.  Finally in the Type row enter the 

type of the test that you want.  Choose 3 (for unequal variances) as the type of your test.  When 

you are done the dialog box should look like this: 

 

 

You can see the p-value associated with this test at the bottom where it says formula result.  

When you click OK, Excel will put the same result into the cell on which you clicked before 

starting the test.   

 

Another way to do the same thing is typing =TTEST(A2:A31,B2:B31,1,3) directly into the cell.   
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Regression 

 

In this section we will use the data in capm.xls, also available on the web. 

 

The command you will probably use most frequently is Statistics > Regression.  By using this 

command you will obtain the following dialog box: 

 

 

 

Choose the dependent variable from the list of variables, and check the boxes for the appropriate 

independent variables.  We will choose smstk as our dependent variable and sp500, crpbon and 

tbill as our independent variables.   

 

When you click Perform regression, Kstat will create 3 worksheets: Regression, ANOVA and 

Residuals.  The active worksheet will be Regression, and you will get the following output: 

 
Regression: smstk  

 constant sp500 crpbon tbill 
coefficient -0.0012814 1.36461728 1.5466021 -2.5374467

std error of coef 0.00452835 0.05101924 0.40357477 0.67671508

t-ratio -0.2830 26.7471 3.8323 -3.7497

p-value 77.7450% 0.0000% 0.0163% 0.0223%

beta-weight 0.8455 0.1399 -0.1349
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standard error of regression 0.06575673

R-squared 77.31%  

adjusted R-squared 77.02%  

  

number of observations 240

residual degrees of freedom 236

   

t-statistic for computing 
95%-confidence intervals 1.9701

 

  

You may have noticed that some of the cells on the Regression worksheet and other worksheets 

have red dots on the upper right corner.  These are called cell comments.  These comments will 

provide you a brief explanation of the content of the cell.  To see a cell comment just put the 

cursor on the red dot in that cell and the comment will display automatically. 

 

From the output above, we can see that our regression equation is, smstk = - 0.0012814 + 

1.36461728*sp500 + 1.5466021*crpbon - 2.5374467*tbill.  We also get the standard errors, t-ratios, 

and p-values and beta-weights for each coefficient, as well as the standard error of the regression, 

R 2 and adjusted R 2 .  Kstat also provides the number of observations, the degrees of freedom of 

the error term, and the t-statistic for computing 95 % confidence intervals. 

 

Now, you can switch to the ANOVA worksheet.  The output in this worksheet looks like this: 

 
Analysis of variance 

  

 sum of squares df 
regression 3.476071636 3

residual 1.020451604 236

total 4.496523241 239

 

F-ratio 267.9705

degrees of freedom ( 3, 236 )

p-value 0.00000%
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We obtained explained (regression) sum of squares, residual sum of squares, total sum of squares, 

F-ratio, degrees of freedom and p-value.  The p-value above is for the hypothesis test with the 

null hypothesis that all the coefficients are equal to zero.  The p-value of 0 says that we can reject 

the null hypothesis with very high confidence.   

 

Finally switch to the Residuals worksheet.  This worksheet provides the predicted (or fitted) 

values and residuals for each observation in the data set. 

 

To make predictions using your most recently performed regression, click Statistics>Prediction.  

In the worksheet that you obtain you can make predictions and calculate confidence and 

prediction intervals.  Suppose we want the predicted value for smstk where sp500=0.05, 

crpbon=0.01 and tbill=0.02.  Enter these numbers into the yellow cells corresponding to each 

variable and click Predict.  You will obtain the following output: 

 

 this page you can also obtain confidence and prediction intervals for the fitted values.  To 

  

 

 

In

change the confidence level just type the confidence level that you want in the cell C12.  The 

confidence and prediction intervals are going to automatically adjust for this confidence level. 
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If you want to do multiple predictions click on Make multiple predictions button.  Suppose we 

want to make predictions for sp500=0.05, crpbon=0.01 and tbill=0.02, as well as sp500=0.02, 

crpbon=-0.02 and tbill=0.03.  Now you need to enter each set of values for the independent 

variables in a separate yellow column.  Also, this time, let’s find the confidence and prediction 

intervals for 90% confidence level.  After you click Predict, the worksheet should look like this: 

 

 

 

After performing a regression you can use some other advanced options by clicking 

Statistics>Model analysis.  This option will expand the Residuals worksheet and it will provide 

some useful statistics (See below for an example of what the output will look like.) In particular, 

in addition to everything that was already in the Residuals worksheet,  you can obtain the test  

statistic for the Breusch-Pagan heteroskedasticity test, variance inflation factors for the 

coefficients, and identify outliers and high leverage points, all of which will be used in the course.   
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Graphs 

 

In this section we will use the data in adsales.xls, also available on the web.  Import this data into 

Kstat. 

 

To plot one variable in your data against another, such as Y vs. X, click 

Statistics>Charts>Scatterplots and then choose the variables from the dialog box that appears.   

 

 you want the regression line to appear on your graph, you need to check the plot regression line 

 

If

box.  By clicking OK above, you can plot exp against sales and also see the regression line: 

 

 11



 

Scatterplot

0

1

2

3

4

5

6

13 14 15 16 17 18 19 20

sales
Regression Equation: y = 0.8574x - 12.189

ex
p

 

 

If you want to save this chart as a worksheet click on the Save button.  You can graph any two 

variables from your data worksheet in this way.   

 

In evaluating a regression, the graph of residuals versus predicted values will come up often.  

First  run a regression where exp is the dependent variable and sales is the independent variable.  

Then click Statistics>Charts>Residual Plots.  You will obtain the following dialog box: 

 

 

Choose predicted values as shown above and click OK.  Kstat automatically uses the residuals 

from the most recent regression you have performed in your current session.  You will obtain the 

following graph for residuals against the predicted values: 
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To include the graph in a Word file, first save the graph.  Your graph will be saved in a worksheet 

named Kept1.  (If you save more than one graph during a session your later graphs will be saved 

in worksheets Kept2, Kept3, etc. in the order that you saved them.)  Switch to Kept1 and click 

on the graph (in the white area not the gray area).  Then click Edit > Copy.  The graph will be 

copied into the clipboard and can now be pasted into Word.   

 

Getting P-values 

 

In this section we will use the data in circul.xls, also available on the web.  We ran a regression 

for Sunday against Daily and we got this output: 

 
Regression: Sunday  

 constant Daily 
coefficient 24.7631585 1.35117342

std error of coef 46.9866631 0.09297695

t-ratio 0.5270 14.5323

p-value 60.1701% 0.0000%

beta-weight  0.9300
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standard error of regression 143.864401

R-squared  86.49%

adjusted R-squared  86.08%

  

number of observations 35

residual degrees of freedom 33

  

t-statistic for computing 
95%-confidence intervals 2.0345

 

 

Remember that the p-value of 0.000 above is for one particular hypothesis test, where the null 

hypothesis is that β1, the coefficient of daily, is equal to zero.  This p-value says that we can reject 

the null with very high confidence; we can be (virtually) 100% sure that β1 is not zero.  If we 

wanted to test some other null hypothesis—for example, β1=1.1—we would have to do the test 

manually.  The t-statistic in this case is 

 

135117342 11
0 09297695

2 7015
. .

.
.

−
=    

 

Now we can use Excel to look up the p-value corresponding to this value of t.  First click on an 

empty cell on the worksheet that you are in.  Click on Insert> Function… to get the Paste 

Function  dialog box: 

 

 14



 

 

Choose Statistical from the Function Category window and choose TDIST from the Function 

Name window.  Then click OK.  You will move to the next step. 

 

 

As shown above, enter the t-statistic in the first row, degrees of freedom in the second row and, 

since we are talking about the probability associated with a two-tailed test, enter 2 in the third 

row.  Now, at the bottom of the dialog box you can read the p-value associated with this test as 

the formula result.  If you click OK, you will see =TDIST(2.7015,33,2) typed in the cell.  You 

could also type this directly into the cell.  In any case you should get the value 0.010812805. 

 

So our p-value is 0.010812805; that is, if the coefficient on exper were really 1.1, there would 

only be a 1.081% chance of obtaining a coefficient as far away as 1.35117342 simply because of 
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randomness in the data.  So we would reject the null hypothesis at any confidence level up to 

about 99%. 

 

We can also use Excel instead of a table to find critical values of t.  If we wanted to find the t-

tatistic corresponding to α = .10 for our two-tailed test, click on Insert> Function… to get the 

ype the sum of the probabilities you want in both tails, which is 0.10, to the first row, and enter 

e degrees of freedom into the second row.  The formula result tells us the t-statistic is 1.692.  So 

orresponding to z=2.7.  First click on an empty cell on the worksheet that you are in.  Click on 

s

Paste Function  dialog box.  Choose Statistical from the Function Category window and 

choose TINV from the Function Name window.  Then click OK.  You will obtain the next 

window: 

 

 

 

T

th

we would reject the null with  α = .10 if we obtained a t-statistic greater than 1.692 or less than -

1.692 (which we did).  This also tells us that for a one-sided test with a ‘‘greater than’’ 

alternative, we would reject the null for α = .05 if we obtained a t-statistic greater than 1.692.   

 

We can also use Excel instead of a z-table.  Suppose we want to look up the p-value 

c

Insert> Function… to get the Paste Function  dialog box.  Choose Statistical from the 

Function Category window and choose NORMSDIST from the Function Name window.  

Then click OK.  You will obtain the next window: 
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As shown above, enter the z value in the first row.  Now, as the formula result you can read 

P(Z<=2.7) = 0.996533.  If you click OK this will appear in the cell.  The p-value for a two-tailed 

test would then be 2*(1 - P(Z<=2.7)) = 0.006934.  For an upper-tailed test it would be 1 - 

P(Z<=2.7)=0.003467.  You need to do these auxiliary calculations 

 

Suppose we wanted to find the z-statistic corresponding to α = .10 for a two-tailed test.  Click on 

Insert> Function… to get the Paste Function  dialog box.  Choose Statistical from the 

Function Category window and choose NORMSINV from the Function Name window.  Then 

click OK.  You will obtain the next window: 

 

 

 

This time we input the area and Excel gives us the z-statistic.  In the following dialog box when 

you enter the probability p , Excel will give you the number x such that there is a probability p of 

being less than x.  We want the number x such that there is a 5% (i.e., α/2%) chance of being 

greater than x, or a 95% chance of being less than x.  So type 0.95 into the dialog box.  The 

formula result tells us the appropriate z-statistic is 1.6448.   
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Creating  New Variables 

 

Sometimes you will need to make a new variable out of the ones given in a file.  For example, 

you may want to use the logarithm of a variable as a predictor or response.  As an example, let’s 

create a  new column, which includes the logarithm of the variable exp.  To do this first import 

the adsales.xls data and go to cell C1 on the data worksheet.  Type in the cell C1 the name you 

want to give to the new variable, say lnexp.  Then click on the cell C2, and click 

Insert>Functions… You will obtain the following Paste Function dialog box: 

 

 

 

From the Function Category window choose Math & Trig, and then choose LN from the 

Function Name window (There are different kinds of logarithms, LN stands for natural 

logarithm, and we will be using natural logarithms in this course).  Now click OK.  You will see 

the following dialog box:  
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Click on the cell A2 (which is the cell whose logarithm you want in the cell C2).  Finally click 

OK.  At this point in the cell C2, you should have =LN(A2).  You can also type this directly into 

the cell.  Now, you can copy and paste this formula into the rest of the column C, where there are 

corresponding observations in column A.  When you are done the worksheet will look like this: 

 

 

Now we are done.  We created a new variable called lnexp.  Each observation in lnexp is the 

logarithm of the corresponding observation in exp.   

 

There are many other mathematical functions built in Excel that you can use to manipulate data, 

and we suggest you to have a look at them and experiment with some of them. 
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Another type of variable that we may want to create using Excel is a  seasonal dummy variable.  

In the “Soda Sales” data set, we had the dummy variables winter, spring, and summer.  Winter, 

for example, was a column with the following sequence of numbers: 

 1 0 0 0 1 0 0 0 1 0 0 0 1 0 0 0 

We had a one for each row of data that corresponded to a winter quarter, and a zero for any other 

quarter.  One way to do this is first typing winter in the first cell of the column you want to create 

the variable in, typing a 1 into the second cell of the column, and typing three 0’s into the third, 

fourth and fifth cells.  Then, copy these cells into the clipboard and finally paste it by choosing 

the appropriate cells.  In the soda example you need to paste this pattern three more times.   

 

In the Florida Bottler data set, we had the variables time, cases, plant, and caseplant.  Plant 

was a dummy variable equal to zero for the Pensacola plant and one for the Tallahassee plant.  

Caseplant was the product of cases and plant (if you don’t remember how this was used, see 

Chapter 5 of the case packet).  Let’s say we weren’t given caseplant and had to create it.  Again 

type caseplant in the first cell of the column you want to create the variable in.  The worksheet 

should look like something like this: 
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Now type =B2*C2 into cell D2, and click on the check button or press enter.  Finally again copy 

the contents of this cell into the clipboard and paste into the appropriate cells.  When you are 

done the worksheet should look like this: 
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